[isf-wifidog] Smarty Template Question & Wifidog Variables

Jason Potter jason at hugedigital.com
Jeu 4 Nov 02:32:50 EDT 2010


Hi there,

I have trying to include the following variables in a Smarty template
content item but they keep ending up blank:
{$gw_address}
{$gw_port}
{$gw_id}

I am assigning them in the /login/index.php page like so:
$ui->smarty->assign('gw_address', $gw_address);
$ui->smarty->assign('gw_port', $gw_port);
$ui->smarty->assign('gw_id', $gw_id);
$ui->smarty->assign('host', $host);

If I put the assigned smarty variable into the MainUI_Display.tpl template
they display their values but if you put it into the content of a Smarty
template object they do not display.  I have tested the suggested code of
{debug output='html'} and can see all the variables displayed with their
values and when I use {$nodeId} it displays the information correctly.

I have found that the nodeId value is setup in the fetch method of the
SmartyWifidog and I have played around with assigning test variables there
and they do get resolved when i put them into the Smarty template object
content.

The only thing I can think of is that when each content itme is processed
the Smarty object is created each time so the assignment statement of
$ui->smarty->assign in the /login/index.php file is not referring to the
correct Smarty object.

Any help would be greatly appreciated.

Regards
Jason
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://listes.ilesansfil.org/pipermail/wifidog/attachments/20101104/d7e921d6/attachment.htm>


Plus d'informations sur la liste de diffusion WiFiDog