[isf-wifidog] Lot WiFiDog, Vol 55, Parution 12

mackay mackay at otenet.gr
Mer 19 Aou 06:21:15 EDT 2009

Thanks Dave,

I had a look at the Networks table and that looks fine to me.

So I did a db dump (pg_dump -U postgres -b -o -v -f ./dump.dump wifidog)
and have uploaded the dump file here http://auth.corfunet.com/dump.dump

But a dump of the users, network_stakeholders, server_stakeholders, 
networks, nodes, roles, server and virtual_hosts tables I have appended it 
to http://auth.corfunet.com/install.txt

To be honest I cannot find/see anything wrong with the tables.

I did a swap of the user_id in the network_stakeholders, and 
server_stakeholders with the guest account's user_id to elevate his 
privaliges and was able to log in.
This suggests to me that something is or went wrong with the user_id for the 
admin account.

... hmmm could it be that I ticked the 'Make this Virtual Host the server's 
default' in the Virtual host managment window when I added my new virtual 
(following the tutorial at 
http://dev.wifidog.org/wiki/doc/admin/GettingStarted and ticking the 'Make 
this Virtual Host the server's default' near the end)
This would change the "localhost" virtual host not to be the default? but 
this would imply the admin account is liked in some way to the 
default-network authenticator.

i.e. the login process is is based on username, password and default server
and not the username / password.

Any ideas.

Kind regards
Stephen Mackay


Message: 1
Date: Tue, 18 Aug 2009 12:12:34 -0700 (PDT)
From: Dave Lamb <delphi9_1971 at yahoo.com>
To: wifidog at listes.ilesansfil.org
Subject: Re: [isf-wifidog] Lot WiFiDog, Vol 55, Parution 11
Message-ID: <374958.78537.qm at web33507.mail.mud.yahoo.com>
Content-Type: text/plain; charset="iso-8859-1"


When I had that problem, I was on the page where you can edit the network.
I navigated away from that screen (without hitting save) and all that I can
surmise that happened is some how the value of the "Authenticator Parameter"
field was cleared and that change was saved.  Essentially what happens is
your network no longer knows where to send authentication requests.  I found
this by going in to PostgreSQL and doing a select statement on the Network
table to reveiw the parameters.  I found this field to be empty when it
shouldn't have been.  I then issued an update sql statement to replace that
value with the correct value.  Since I'm using local authentication and I'm
using the original "default-network", "default-network" was the value I had
to replace.  If you're not using the default network, then you need to enter
the network ID or LDAP parameters if you're authenticating to LDAP.  That
will be specific to your implementation.

 Dave Lamb, CCNA, Network+
312-560-6933 C

From: "wifidog-request at listes.ilesansfil.org"
<wifidog-request at listes.ilesansfil.org>
To: wifidog at listes.ilesansfil.org
Sent: Tuesday, August 18, 2009 11:00:02 AM
Subject: Lot WiFiDog, Vol 55, Parution 11

Envoyez vos messages pour la liste WiFiDog à
    wifidog at listes.ilesansfil.org

Pour vous (dés)abonner par le web, consultez

ou, par email, envoyez un message avec 'help' dans le corps ou dans le
sujet à
    wifidog-request at listes.ilesansfil.org

Vous pouvez contacter l'administrateur de la liste à l'adresse
    wifidog-owner at listes.ilesansfil.org

Si vous répondez, n'oubliez pas de changer l'objet du message afin
qu'il soit plus spécifique que "Re: Contenu du digest de WiFiDog..."

Thèmes du jour :

   1. Another Lost admin account (mackay)


Message: 1
Date: Tue, 18 Aug 2009 14:26:17 +0300
From: "mackay" <mackay at otenet.gr>
To: <wifidog at listes.ilesansfil.org>
Subject: [isf-wifidog] Another Lost admin account
Message-ID: <D3E65978333A4A6FAD8D197552BA6226 at vaio>
Content-Type: text/plain; format=flowed; charset="iso-8859-1";


I have much the same problem as Dave Lamb, I am running wifidog on a VMWARE
image with Debian Lenny:
Linux web02 2.6.26-2-686 #1 SMP Sun Jun 21 04:57:38 UTC 2009 i686 GNU/Linux

It was all working fine until I logged out from admin  to simulate a new
user creating a free account.
I created a new user and was able to log in without a problem.
I logged out as the new user and when I came to log back in as admin and I
get 'unknown user name or password'. (even if I use the email address)
I do not have a problem logging in as the new user.

I also looked at the user table in postgres and that looks OK, I even
updated the admin password but still no luck.

I has happened to me a few times and I have just recovered from a snapshot.
But this will not be ok in a live environment so I need a solution to this.

In the install I used
postgres 8.3
jpgraph-1.22 -> jpgraph-1.22.1
PHPMailer_v2.0.0 -> PHPMailer_v2.1
You can see my history after a clean standard install of Debian Lenny at
Notes: Line 3, I setup a static IP, Line 34 see vhost file at end of History

(not sure about  <Directory /var/www/wifidog-auth/wifidog/>). I also did not

see a rewrite at aprox line 17 as is in the howto

Is there a clean install as a vmware image that I can download from
anywhere/anyone or
can everyone please list
1) what OS you are using,
2) what ver of Postgres you use
3) if you use any upgraded packages (i.e.  PHPMailer_v2.1)

Any help would be much appreciated.

Kind Regards
Stephen Mackay


WiFiDog mailing list
WiFiDog at listes.ilesansfil.org

Fin de Lot WiFiDog, Vol 55, Parution 11

-------------- section suivante --------------
Une pièce jointe HTML a été nettoyée...


Message: 2
Date: Tue, 18 Aug 2009 18:03:49 -0400
From: "Hardwick, Keith (DS-1)" <KHardwick at drs-tsi.com>
To: <wifidog at listes.ilesansfil.org>
Subject: [isf-wifidog] PHPMailer issue
<EE55E36AAB4808439C74D4B2306165A3B9A15C at TSIMAIL.tsi.drs.master>
Content-Type: text/plain; charset="iso-8859-1"


I have an auth-server that has been running r1355 and I wanted to
upgrade to current version r1413 so that the abuse settings and controls
work (which they do--very well) but my problem is since I upgraded to
the current version, I receive error messages every time the auth server
sends an email.

This is the error I get when I use lost_password "PHPMailer couldn't
sent mail. Error was: SMTP Error: The following SMTP Error: Data not
accepted. khardwick@ drs-tsi.com"
 The same error when I resend validation email "PHPMailer couldn't sent
mail. Error was: SMTP Error: The following SMTP Error: Data not
accepted.khardwick at drs-tsi.com"
The same error on validation resend as well.
If I rollback to r1355 everything works fine and the email goes through
with no problems.

In my wifidog.config line there is the following statement:

  * Email configuration
  * ===============================
  * Internal configuration values for WiFiDog - don't touch!

define('EMAIL_MAILER', 'stmp'); // "mail", "sendmail", or "smtp"

// Valid only for SMTP
define('EMAIL_HOST', '');
define('EMAIL_AUTH', false);

// Valid if EMAIL_AUTH is true
define('EMAIL_USERNAME', '');
define('EMAIL_PASSWORD', '');


Does anyone have any suggestions ?

Thank you,

Keith Hardwick
-------------- section suivante --------------
Une pièce jointe HTML a été nettoyée...


WiFiDog mailing list
WiFiDog at listes.ilesansfil.org

Fin de Lot WiFiDog, Vol 55, Parution 12


No virus found in this incoming message.
Checked by AVG - www.avg.com
Version: 8.5.392 / Virus Database: 270.13.60/2311 - Release Date: 08/18/09 

Plus d'informations sur la liste de diffusion WiFiDog