[isf-wifidog] Submitting trouble ticked not functioning. - Router quits after power down. Reply

Don Druce dondruce at sympatico.ca
Lun 31 Déc 16:26:25 EST 2007

Thanks Robin

I am aware that three tickets were posted on the same subject.  When I 
posted the first two, I received absolutely no indication that things 
were working.  I got the cursor with a hourglass and it just stayed 
there.  I assumed that things were not working and simply disconnected.  
I finally got results on the third try.

As to your response, are you telling me that if there is a short power  
failure, at the router, customers will lose their connection and will 
not be able to get back on until the session closes on the auth server.  
If so, how long does that take.  Also if so, I for one will start 
advising people, because I was not aware of that at all.

As part of my testing of WiFiDog 1.1.4 Security on a couple of routers, 
I connected, then pulled the router's power plug for a minute or two and 
then tried to log back on.  I got nowhere, which is what I was trying to 
explain in my message, and on the Trouble Ticket. 

If I am reading you right
1) What would be the proper procedure to get things working again, pull 
the power plug on the router for an hour or so.
2) Advise customers that are using the router that they will not be able 
to get back online for xx time.
3)  How come on an older router using WifiDog 1.1.3, I get the Green 
Screen and I can click and reconnect.
4) On the routers that I am testing with WifiDog 1.1.4, I get nowhere, 
BUT if I go to my Sympatico Modem/Router, I see the 
Green Screen and when I go to Status is tells me the the Internet is not 
connected.  Going to my Router with PuTTY and typing     WiFidog-init 
status,   gives me the same result.

I can send some screen shots.

5) We at MSF ( me for positive, others to my knowledge) are not aware of 
that and do not have that documented anywhere that I know of.

Many many thanks.

Robin Jones wrote:
> Hi Don,
> Dev.wifidog.org is working fine!!! You have posted 3 tickets yesterday
> (2 of them are duplicates)
> Bernoit answered: I'm having a bit of trouble understanding your
> description (exactly what you are unplugging, and what you mean by log
> on). However it sounds like you are getting the expected behaviour. If
> you shutdown your laptop, wifidog is supposed to end your session. If
> you leave your laptop on (and not sleeping) your session should never
> end. 
> I will answer: http://dev.wifidog.org/wiki/doc/developer/FlowDiagram. I
> beleive the reason for the problem you are having, is because you have
> authenticated and started a session on the authentication server and the
> node has been informed of this, when you pull the plug on a node, it
> will loose the ram of who is allowed through the firewall, thus giving
> you a 401 error. When the session finally ends on the auth server (or it
> is restarted) the client will be able to reconnect!
> Robin Jones.
> -----Original Message-----
> From: wifidog-bounces at listes.ilesansfil.org
> [mailto:wifidog-bounces at listes.ilesansfil.org] On Behalf Of Don Druce
> Sent: 30 December 2007 20:37
> To: WiFiDog Captive Portal
> Subject: [isf-wifidog] Submitting trouble ticked not functioning. -
> Router quits after power down.
> Is http://dev.wifidog.org down, I am trying to submit a ticket without 
> success.
> I will post the problem here in the meantime.  Perhaps someone has an 
> answer.
> ------------------------------------------------------------------------
> ------
> I used    (the following is as directed by CQSF - I am with Monteregie 
> sans fil and work under their direction)
> OpenWrt
> Kernel Version Linux version 2.4.30 (nbd at ds10) (gcc version 3.4.4 
> (OpenWrt-1.0)) #1 Sat Feb 3 13:16:08 CET 2007
> &
> Wifidog 1.1.4    (CQSF recommends 1.1.3b2, but I am testing with 1.1.4,)
> To flash a Linksys WRT54GL router.   
> When I get it working, I can reach the Internet, and it resets properly 
> after any idle period, and I can log back on to the Internet.
> If I pull the power plug for a few minutes, and then try to come back 
> online, I end up with http://www.google.ca/ in the address bar and the 
> [page cannot be displayed] page on the screen.
> Should I not be redirected to the Green Screen
> On another router running Wifidog 1.1.3 this is what happens, and after 
> clicking ''click here'' I am back online.
> During one test, I turned the computer off for the night, left the 
> router on, and the next morning I could log back on.  There also was one
> occasion where I could get back on about 50 minutes later, but generally
> it will not allow me to get back online.
> Associated Questions
> Where can I find a good description of the redirect process - that I can
> use?
> Am I using the proper version of OpenWrt, - what is and how can I find 
> the proper version, what is the latest version, where do I get a copy.
> Any other comments appreciated.
> Thanks
> _______________________________________________
> WiFiDog mailing list
> WiFiDog at listes.ilesansfil.org
> http://listes.ilesansfil.org/cgi-bin/mailman/listinfo/wifidog
> _______________________________________________
> WiFiDog mailing list
> WiFiDog at listes.ilesansfil.org
> http://listes.ilesansfil.org/cgi-bin/mailman/listinfo/wifidog

Plus d'informations sur la liste de diffusion WiFiDog