[isf-wifidog] solved: Re: Redirection page: broken link, "unlocking" doesn't work

Alexander List alex at list.priv.at
Jeu 14 Sep 12:07:14 EDT 2006

Alexander List wrote:
> Alexander List wrote:
>> a) The redirection page I get says "click here" to log in. "Here" isn't
>> linked to anything, just plain text. Without knowing the correct URL of
>> the auth server, users have no chance to log in.
>> b) After successfully logging in, users still get the "redirect" page.
>> It's not the browser cache or anything - "unlocking" just doesn't work.
> OK, it seems that this problem only affects Firefox users.


The problem was an extra space in the Wifidog gateway configuration at

AuthServer {
    Hostname my.auth.server
    Path /wifidog/

There must be absolutely no whitespace after my.auth.server!

I consider this a bug. Host names must not contain whitespace, so any
kind of whitespace after the hostname should be stripped from this
variable. I wasn't the only one who was caught by this one...


Plus d'informations sur la liste de diffusion WiFiDog