[isf-wifidog] Auth server sends 1 then 0 for validated user

Max Horváth max.horvath at maxspot.de
Lun 15 Mai 02:47:26 EDT 2006

Hash: SHA1


it ***seem*** I resolved the problems we had - but I'm not sure yet,  
as I have to wait for any reports ...

I was running nbds qos-scripts on the router ... everytime an  
interface does ifup the script gets restarted and runs a lot of  
commands - including iptables commands. Restarting the script I could  
replicate out issue immediately ... so now I'm restarting wifidog  
when the script gets restarted ...

BTW, what is the cleanest way to restart wifidog? right now i do a  
"killall wifidog && sleep 5 && /etc/init.d/S65wifidog" ...

I hope I solved the problems we were experiencing - but reading all  
those emails I'm not too sure :( ...

Cheers, Max

PS: I don't think it's the server ... the last update of our server  
was 2 weeks before we met in St. Louis ...

Am 15.05.2006 um 06:14 schrieb Gabe Sawhney:

> When I read Max's post about downgrading, I tried it -- initially I
> was using RC5 and 1.1.3 beta3 (or 4? I forget), so then I tried RC3
> and the beta2 image at:
> http://www.ilesansfil.org/dist/wifidog/bin/openwrt/whiterussian-rc3/
> It made no difference.  So yeah, it seems to me like it's something on
> the server.  I think Rob last updated our auth server a few weeks
> ago...
> Gabe
> On 5/15/06, Benoit Grégoire <bock at step.polymtl.ca> wrote:
>> On Sunday 14 May 2006 17:40, Cara Ward wrote:
>> > Hi,
>> >
>> > I'm relatively new to the wifidog community and am having  
>> trouble getting
>> > wifidog working.  My validated users are redirected to the login  
>> page
>> > instead of out to the Internet.  The wifidog log shows that the  
>> Auth
>> > server gets an allow initially, but shortly after sends a deny.   
>> I cannot
>> > figure out why the client is denied.
>> > I am running WiFidog version 1.1.3_beta4.  I tried to install  
>> the latest
>> > revision on my auth server, but had to revert to r1029 as 1034 kept
>> > complaining that smarty template was not installed even though  
>> it was.
>> > 1029 installed fine.
>> > I am using a debian based pc for the gateway.  ipt_mac is  
>> loaded; the
>> > relevant portions of lsmod are below as is the wifidog debug log.
>> >
>> > The account status of the denied users is set to 1 in the users  
>> table of
>> > the db.
>> > My authenticator is LocalUser.
>> >
>> > I cannot figure out from the logs why my auth server sends the  
>> second
>> > deny after first allowing my clients.  Any suggestions as to why  
>> this
>> > might be happening? Thanks in advance for any assistance -
>> All right, this sounds just like:
>> -Max's current difficulties
>> -Problem's I read wireless toronto had with splash only mode.
>> So unless Max confirms that downgrading the gateway made it go  
>> away, it now
>> seems very likely that someone broke auth in the auth server.
> _______________________________________________
> WiFiDog mailing list
> WiFiDog at listes.ilesansfil.org
> http://listes.ilesansfil.org/cgi-bin/mailman/listinfo/wifidog

Version: GnuPG v1.4.1 (Darwin)


More information about the WiFiDog mailing list