[isf-wifidog] RE: Wifidog installation question

Ronit Fuhrmann ronit at toroki.com
Mer 10 Mai 14:27:34 EDT 2006


I believe I solved the problem. Maybe this information will help other

Problem description:

In the test.php. After a record is created in the users table, this select
statement is been executed:
SELECT * FROM users NATURAL JOIN administrators WHERE account_origin =

However, the record was created with account_origin= 'default-network'.

What I did to solve the problem:

1) Changed test.php. Replaced 'LOCAL_USER' with 'default-network' (in the
select statement).
2) I manually deleted the record from the users table.
3) Loaded "Administration Account" page again, and recreated the admin

It worked!



Ronit Fuhrmann
Toroki, Inc.                      Office: +1 (408) 773-2777
1230 Oakmead Pkwy         Mobile: +1 (408) 391-9207
Suite #305                      Fax:    +1 (702) 543-6645
Sunnyvale, CA 94085        Email:  ronit at toroki.com

-----Original Message-----
From: Benoit Gr?goire [mailto:bock at step.polymtl.ca] 
Sent: Wednesday, May 10, 2006 10:28 AM
To: Ronit Fuhrmann; wifidog at listes.ilesansfil.org
Subject: Re: Wifidog installation question

On May 10, 2006 01:08 pm, you wrote:
> Hi,
> I am new to wifidog community. I ran into a problem running the 
> install.php, and I was hoping you might be able to help me.
> I am unable to pass the "administration account" page.
> I enter the password and confirm the password. Press "Next", and it 
> only refreshes the screen. No error message is displayed.

Is that with latest SVN?

> When I try again, I am getting the error message below:
> --------------------------------------------
> ExecuterSqlResUnique(): ERREUR: Lors de l'exécution de la requête SQL:
> INSERT INTO users (user_id,username,
> account_origin,email,pass,account_status,validation_token,reg_date) 
>('4232fa916e6321fab13fad833e752457','admin','default-network','root at loc
> L'erreur est:
> ERROR: duplicate key violates unique constraint 
> "idx_unique_username_and_account_origin"
> -------------------------------------------
> I understand that this error message results from the fact that admin 
> account was already created, but do not know why it did not work the 
> fist time around.
> I appreciate your help.

I may not be the best person to ask, I didn't write the install script.  
However, try backing up two pages, normally (I presume) it shouldn't ask you
to create an administrative account again.

Benoit Grégoire, http://benoitg.coeus.ca/

More information about the WiFiDog mailing list