[isf-wifidog] installation problems

Elie Zananiri prisonerjohn at gmail.com
Mer 3 Mai 12:57:00 EDT 2006

Hi all,

I am trying to install the WiFiDog Authentication Server on my  
computer and I am having a few problems (with the install.php)

1) When I get to the Smarty installation section, this is what gets  
Smarty installation

Smarty is known as a "Template Engine". Wifidog s internal  
fonctionnality needs it.

Download source code (Smarty-2.6.7.tar.gz) : Error
Current working directory : /Users/lilo/Sites/wifidog-auth-1.0.0_m2/ 
wget "http://smarty.php.net/do_download.php? 
sh: line 1: wget: command not found

I manually downloaded Smarty and installed it but it is version  
2.6.13  Should I get v2.6.7 instead?  How come I am getting this error?

I looked through the code and found that there are 2 "if (! 
$filename) ..." statements following each other, so I figured one of  
them must be the opposite.  I modified it and got passed that point.

2) I get the same error when I try to install the MagpieRSS  
extension, so I bypassed it too.

3) When I get to the new Admin page, after I insert a new name and  
password, it enters it in the database but I don't get the option to  
go to the next screen.  The same content just refreshes (clearing the  
text fields) and that's where I'm stuck now.

Any ideas?

I'm using Mac OS X with PostgreSQL 8.1.3.  Everything up until the  
Smarty installation worked fine, except that I got warnings on my  
radius, Auth_RADIUS, Crypt_CHAP components.  I tried running the page  
in both Firefox and Safari browsers.  I should also mention that I am  
pretty much a Linux beginner so please go slow with me :)

Thanks for the help!


More information about the WiFiDog mailing list