[isf-wifidog] WifiDog Smarty translations

Rajendra Jagad rjagad at gmail.com
Jeu 24 Aou 00:16:56 EDT 2006

I have smarty problem but of different kind. I install the authtentication
server Ran the http://localhost:localdomain/wifidogpath/install.php

After I click on next button I get
PHP    OK    5.1.4

Extention    Status    Note    Message
xml    OK    Required for RSS support
pgsql    OK    Required to connect to Postgresql database
mysql    Warning    Required to connect to MySQL database (experimental and
not working)    MySQL extention is missing
dom    OK    Required if you want to export the list of HotSpots as a RSS
gettext    OK    Internationalization support
mbstring    OK    Required for core auth-server and RSS support
mcrypt    OK    Required for RADIUS support
mhash    OK    Required for RADIUS support
xmlrpc    OK    Required for RADIUS support

Component    Status    Note
radius    Warning    Try in command line : pear install radius
Auth_RADIUS    Warning    Try in command line : pear install Auth_RADIUS
Crypt_CHAP    OK

Todo : PostgreSLQ and MySQL version are not validate

Now the 3 warning can be ingnored becuase those are optionals installs so I
believe I can Ignore them. when I click on next button
 the permission required by wifidog are check and TIP is given That Tip
really help me fix the problem quickly, GREAT WORK ON That guys..

Home: /var/www/html/wifidog/wifidog

HTTPD username/group: apache/apache
Directory    Owner    Writable
tmp    apache    YES
tmp/magpie_cache    apache    YES
lib/smarty    apache    YES
tmp/smarty/templates_c    apache    YES
lib/magpie    apache    YES
lib/Phlickr    apache    YES
config.php    apache    YES
 Here is where I run into problem. when I click next
Smarty installation

Smarty is known as a "Template Engine". Wifidog s internal fonctionnality
needs it.
Download source code (Smarty-2.6.7.tar.gz) : Error

Current working directory : /var/www/html/wifidog/wifidog/tmp/smarty

wget "
           => `do_download.php?download_file=Smarty-2.6.7.tar.gz'
Resolving smarty.php.net... failed: Temporary failure in name resolution.

I check the download path it is still good. But this scripts want to
untar this smarty-2.6.7.. And  its not happening nor the download.
So I manully downloaded smarty 2.6.7 and not 2.6.14 an
copied the files form the libs directory to the php include path so these
class and includes files are aviable when the smarty that came with
Authenication server runs.

How do I fix the problem so the smarty installation problem disappear.. ??
or does the script needs to be changed. ?


On 8/23/06, François Proulx <fproulx at edito.qc.ca> wrote:
> Hi everyone,
> Today, I have finally solved the problem we've been having for many months
> regarding translation of strings with variables in our Smarty templates.
> All we needed is to know the awkward Smarty syntax. So here is how to use
> it, if you are playing with the templates.
> ex.
> {"The %s network currently has %d valid users."
> |_|sprintf:$networkName:$networkNumValidUsers}
> It is basically piping the sprintf-formatted string to Gettext for i18n,
> then filtering it through the sprintf for spot replacements. I updated the
> scripts to match the new regexp and fully updated the French translations,
> this will be committed along with other stuff before I leave for Boston next
> week.
> See ya !
> François
> _______________________________________________
> WiFiDog mailing list
> WiFiDog at listes.ilesansfil.org
> http://listes.ilesansfil.org/cgi-bin/mailman/listinfo/wifidog
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://listes.ilesansfil.org/pipermail/wifidog/attachments/20060824/6728908c/attachment-0001.html

Plus d'informations sur la liste de diffusion WiFiDog